Doppelte Einträge in Excel finden - Excel leicht gemacht

Doppelte Einträge in Excel finden ist nicht schwer, wenn man einfache Formeln und den Autofilter benutzt.


Excel ist ein nützliches Programm, um Tabellen für verschiedene Aufgaben anzulegen. Komplexere Tabellen übernehmen Berechnungen oder bieten Überblick über umfangreiche Datensätze. Je größer die Tabelle, desto höher ist aber auch die Chance, dass man Fehler übersieht oder sich Einträge doppelt einschleichen. Bei riesigen Tabellen kann man dies nur mit viel Mühe selber korrigieren. Abhilfe leisten automatisierte Vorgänge, mit denen man doppelte Einträge in Excel finden kann.

 

Doppelte Einträge in Excel finden per Spezialfilter

  • Diese Methode eignet sich für Tabellen mit Spaltenüberschriften. Fügen sie oberhalb der Tabelle drei Leerzeilen ein und kopieren sie die Überschrift der zu bereinigen Spalte in die erste Zeile.
  • Klicken sie danach einfach irgendwo in die Tabelle und wählen sie dann in der oberen Programmleiste im Menü Daten / Filter, den Spezialfilter auf. Dieser markiert sogleich die Tabelle. Im Feld Listenbereich wählt man die zu durchsuchende Spalte aus. Wichtig ist es, den Haken bei „Keine Duplikate“ zu setzen. Danach wird nach Klick auf OK gefiltert.

 

 

Doppelte Einträge in Excel finden per Formel

  • Bei dieser Methode muss man hinter der Spalte mit den doppelten Daten eine zusätzliche Spalte einfügen. In der ersten Zeile dieser Spalte geben Sie die Formel =WENN(C1=C2;“j“;““) ein. Ersetzen Sie C mit dem Buchstaben der Spalte, in der sich die doppelten Einträge befinden. Doppelklick auf die Formel, und sie wird in die gesamte Spalte kopiert.
  • Danach markieren Sie diese Spalte und kopieren sie. Wählen sie in der Dateileiste Bearbeiten und Inhalte einfügen. Im folgenden Dialog wählen sie die Option Werte aus und setzen den Cursor auf die Spalte mit der Formel. Lassen Sie diese Spalte absteigend sortieren. Nun können Sie alle doppelten Einträge löschen, da sie mit „j“ markiert sind.

 

 

Doppelte Einträge in Excel finden mit Hilfe einer anderen Formel und dem Autofilter

  • Für die andere Formel muss man ebenfalls eine neue Spalte anlegen und in die erste Zeile folgende Formel schreiben: =WENN(VERGLEICH(A1;A:A;0)=ZEILE();““;“Doppelt“).
  • Auch diese muss man in die gesamte Spalte kopieren, wobei A wieder durch den Buchstaben der Spalte mit den doppelten Einträgen ersetzt werden muss. Gehen Sie dann im Menü auf Daten, Filter und Autofilter benutzen. So können sie doppelte Einträge in Excel finden.